FAQ
overflow

Great Answers to
Questions About Everything

QUESTION

On my old Toshiba Tecra A2 laptop, I tried installing Ubuntu 12.04 Beta 2.

After burning it to a CD, I tried booting from the CD and got the message:

This kernel requires the following features not present on the CPU:
pae

Unable to boot - please use a kernel appropriate for your CPU.

What does this mean?

{ asked by oshirowanen }

ANSWER

The error message means that your CPU does not support PAE extensions - that is a technique which allows a 32bit CPU to address more than 4GB of memory address space.

By default, 12.04 and later versions of Ubuntu expects a CPU with this capability:

PAE is provided by Intel Pentium Pro and above CPUs, including all later Pentium-series processors (except the 400 MHz-bus versions of the Pentium M). It is also available on other processors with similar or more advanced versions of the same architecture, such as the AMD Athlon[dubious – discuss] and later AMD processor models. wikipedia

While the above is strictly true, old systems which have the memory controller on the motherboard may not "expose" the CPU's PAE support, effectively making them non-PAE.

There is a heated bug report about this; Canonical has decided that the default Ubuntu Desktop install will expect PAE support.

A few suggested workarounds:

Workaround 1: Install Lubuntu or Xubuntu, then install the regular Ubuntu Desktop
Workaround 2: Install an older version and then upgrade to 12.04

Install 10.04 or 11.10 and then upgrade to 12.04. See the linked question below for 12.10.

Workaround 3: If you have a wired internet connection, use the "net install" mini-CD

Linked Question:

  1. How can I tell if a machine has PAE?
  2. Will it be possible to use a non-pae kernel in 12.10
{ answered by fossfreedom }
Tweet